Failure of PyPlot backend in Plots


#1

Hello,
I want to use the pyplot backend to make some 3D scatter plots

using Plots; pyplot()

and I get the following:

sys:1: UserWarning: 
This call to matplotlib.use() has no effect because the backend has already
been chosen; matplotlib.use() must be called *before* pylab, matplotlib.pyplot,
or matplotlib.backends is imported for the first time.

The backend was *originally* set to u'Qt5Agg' by the following code:
  File "/home/pegger/.julia/v0.6/Conda/deps/usr/lib/python2.7/site-packages/matplotlib/backends/__init__.py", line 14, in <module>
    line for line in traceback.format_stack()


WARNING: No working GUI backend found for matplotlib
WARNING: Couldn't initialize pyplot.  (might need to install it?)
INFO: To do a standard install of pyplot, copy and run this:

if !Plots.is_installed("PyPlot")
    Pkg.add("PyPlot")
end
withenv("PYTHON" => "") do
    Pkg.build("PyPlot")
end

I followed the instructions and restarted julia and tried again to use the pyplot backend, and I got the same thing.

Has anyone ever experienced this and how did you solve it?

Thanks,

Philip


#2

My advice is to just use the GR backend. The Conda install of PyPlot hasn’t worked well for a few months (at least on Linux and Windows). Using the system Python tends to work well though, at least on Linux, so we should probably change that error message.


#3

If you are on osx, in particular, many of my students had a lot of trouble with pyplot…and gave up eventually