Error when loading Queryverse: ParquetFiles [46a..27f] is required but does not seem to be installed

I am trying to load Qeuryverse, but facing this issue. Here is the error:

using Queryverse

┌ Info: Precompiling Queryverse [612083be-0b0f-5412-89c1-4e7c75506a58]
└ @ Base loading.jl:1278
ERROR: LoadError: ArgumentError: Package ParquetFiles [46a55296-af5a-53b0-aaa0-97023b66127f] is required but does not seem to be installed:

  • Run Pkg.instantiate() to install all recorded dependencies.

[1] _require(::Base.PkgId) at ./loading.jl:999
[2] require(::Base.PkgId) at ./loading.jl:928
[3] require(::Module, ::Symbol) at ./loading.jl:923
[4] include(::Function, ::Module, ::String) at ./Base.jl:380
[5] include(::Module, ::String) at ./Base.jl:368
[6] top-level scope at none:2
[7] eval at ./boot.jl:331 [inlined]
[8] eval(::Expr) at ./client.jl:467
[9] top-level scope at ./none:3
in expression starting at /Users/birusod/.julia/packages/Queryverse/XPALb/src/Queryverse.jl:15
Failed to precompile Queryverse [612083be-0b0f-5412-89c1-4e7c75506a58] to /Users/birusod/.julia/compiled/v1.5/Queryverse/hLJnW_71U9R.ji.

[1] error(::String) at ./error.jl:33
[2] compilecache(::Base.PkgId, ::String) at ./loading.jl:1305
[3] _require(::Base.PkgId) at ./loading.jl:1030
[4] require(::Base.PkgId) at ./loading.jl:928
[5] require(::Module, ::Symbol) at ./loading.jl:923
[6] include_string(::Function, ::Module, ::String, ::String) at ./loading.jl:1091

I did Pkg.instantiate() and no effect. Any help pointing to a solution is appreciated!

Pretty sure you want to use Parquet.jl to read and write parquet file.s ParquetFiles.jl doesn’t even support Parquet.jl v0.5 and v0.6.

Parquet.jl just needs a sensible and tasteful read_parquet method so that you can do df = DataFrame!(read_parquet(path)) instead of the BatchCursor way now. Something might be in the works in Parquet.jl right now, but I haven’t checked the latest PR.

Thanks for your reply! My problem is not ParquetFiles. I just want to load Queryverse, and so far everything I tried failed. The same error even after removing and r-adding these packages. :frowning:

I see. Just install parquet files first? Bet it’s blocked by parquet or something. Start a new env.

Also report error with queryverse

I did. Still not working. I reported this error on Twitter and got some replies from you and others and I will try reposting it again in case someone else has found how to solve it.

FWIW, On Julia 1.5.1, I do

] activate queryverse-test

using Queryverse


But I think it’s wise to dissociate Queryverse.jl from tidyverse. It’s like an umbrella package like tidyverse, but it’s based on Query.jl which I will never warm to since it will have always have poor group-by performance due to its design.

If you need to manipulate tabular data I would recommend just using DataFrames.jl with DataFramesMeta.jl

If you are adventurous you can look into DataFramesMacros.jl and Volcanito.jl.

Anyway, I am curious, why do you want to use Queryverse? Is it the connotation to tidyverse? Break that connotation if it is. Queryverse is not on par with tidyverse (nothing in Julia is atm since tidyverse is huge but pockets of Julia are excellent).

Hi @xiaodai,
Thanks again. I appreciate your explanation. Coming from R, that was my thinking (the ease of loading tidyverse).
I am glad I can move on and will check the other pkgs you referenced. Thx!