Error: Point2f and Point3f not defined

Hi, I’m trying to use a code that I found in the community. But I cannot run because a error:

 return (Point3f.(xyzos), Float32.(weights))
ERROR: UndefVarError: Point3f not defined

How I can solve one? Mu Julia Version is 1.7.2. I tried to add many packages. But the error continue.

I’m a new Julia’s user.

You need to import some package in order to get the definition of Point3f. Please double check the source where you copied the code to find the necessary imports. You may try using Meshes or using GeometryBasics for example, which are two packages exporting this name.

Do you know the packages and the order? I’m tried to add again the package

   Resolving package versions...
  No Changes to `C:\Users\EvSchulz\.julia\environments\v1.7\Project.toml`
  No Changes to `C:\Users\EvSchulz\.julia\environments\v1.7\Manifest.toml`
  0 dependencies successfully precompiled in 1 seconds (264 already precompiled)
  1 dependency errored. To see a full report either run `import Pkg; Pkg.precompile()` or load the package

but I had a error:

julia> import Pkg; Pkg.precompile("GeometryBasics")
ERROR: MethodError: no method matching precompile(::String)
Closest candidates are:
  precompile(; kwargs...) at C:\Users\EvSchulz\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1011
  precompile(::Pkg.Types.Context; internal_call, strict, warn_loaded, already_instantiated, kwargs...) at C:\Users\EvSchulz\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1012
 [1] top-level scope
   @ REPL[1]:1

Hi @evandro.schulz , I think you should learn the basics of the language first before trying to run this example. Please read the Julia manual to learn more about imports and the Pkg manual to learn more about its commands.

Also, consider the New to Julia category for new questions about basic usage.

The problem is the package Meshes.