ERROR: 'path' appears to be a local path, but directory does not exist

Hi all. This post concerns the following error:

ERROR: 'path' appears to be a local path, but directory does not exist

I am currently following this Readme for a Julia/Python program (BYU CCBlade.ji). I have tried both establishing the path locally using:

(@v1.10) pkg> develop(path="/Users/dblachance/Desktop/BU Research/CC Blade/CCBlade.jl-master/src/CCBlade.jl")

And resulted in the following error:

(@v1.10) pkg> develop /Users/dblachance/Desktop/CCBlade.jl
ERROR: `/Users/dblachance/Desktop/CCBlade.jl` appears to be a local path, but directory does not exist

I also tried the following with no luck as well:

julia> Pkg.add(path="/Users/dblachance/Desktop/CCBlade.jl")
ERROR: Path `/Users/dblachance/Desktop/CCBlade.jl` does not exist.
 [1] pkgerror(msg::String)
   @ Pkg.Types /Applications/
 [2] handle_repo_add!(ctx::Pkg.Types.Context, pkg::Pkg.Types.PackageSpec)
   @ Pkg.Types /Applications/
 [3] handle_repos_add!(ctx::Pkg.Types.Context, pkgs::Vector{Pkg.Types.PackageSpec})
   @ Pkg.Types /Applications/
 [4] add(ctx::Pkg.Types.Context, pkgs::Vector{ā€¦}; preserve::Pkg.Types.PreserveLevel, platform::Base.BinaryPlatforms.Platform, kwargs::@Kwargs{ā€¦})
   @ Pkg.API /Applications/
 [5] add(pkgs::Vector{Pkg.Types.PackageSpec}; io::Base.TTY, kwargs::@Kwargs{})
   @ Pkg.API /Applications/
 [6] add(pkgs::Vector{Pkg.Types.PackageSpec})
   @ Pkg.API /Applications/
 [7] add(; name::Nothing, uuid::Nothing, version::Nothing, url::Nothing, rev::Nothing, path::String, mode::Pkg.Types.PackageMode, subdir::Nothing, kwargs::@Kwargs{})
   @ Pkg.API ./boot.jl:0
 [8] top-level scope
   @ REPL[21]:1
Some type information was truncated. Use `show(err)` to see complete types.

Any helps and tips will be greatly appreciated!

Note* I have a copy of the file in two places, I have tried both methods with the two file locations.


Iā€™m fairly certain that they mean that you should clone the package as CCBlade.jl and give the path to the clone as argument to dev, not the path to the file with the same name inside the repository. Try something like

develop(path="/Users/dblachance/Desktop/BU Research/CC Blade/CCBlade.jl-master")
1 Like

Thank you very much! I tried that and it did not work,

(@v1.10) pkg> develop(path="/Users/dblachance/Desktop/BU Research/CC Blade/CCBlade.jl-master")
ERROR: `develop(path=` is not a recognized command. Type ? for help with available commands

However, when I tried the other way for doing it not using ā€œ]ā€ it worked:

julia> Pkg.develop(path="/Users/dblachance/Desktop/BU Research/CC Blade/CCBlade.jl_master")
   Resolving package versions...
   Installed IrrationalConstants ā”€ā”€ v0.2.2
   Installed DiffResults ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.1.0
   Installed OffsetArrays ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.13.0
   Installed FLOWMath ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v0.3.3
   Installed ImplicitAD ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v0.3.1
   Installed JLLWrappers ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.5.0
   Installed SpecialFunctions ā”€ā”€ā”€ā”€ā”€ v2.3.1
   Installed StaticArraysCore ā”€ā”€ā”€ā”€ā”€ v1.4.2
   Installed NaNMath ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.0.2
   Installed ReverseDiff ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.15.1
   Installed StaticArrays ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.9.1
   Installed ChainRulesCore ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.20.0
   Installed FunctionWrappers ā”€ā”€ā”€ā”€ā”€ v1.1.3
   Installed LogExpFunctions ā”€ā”€ā”€ā”€ā”€ā”€ v0.3.26
   Installed OpenSpecFun_jll ā”€ā”€ā”€ā”€ā”€ā”€ v0.5.5+0
   Installed Compat ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v4.12.0
   Installed CommonSubexpressions ā”€ v0.3.0
   Installed ForwardDiff ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v0.10.36
   Installed DocStringExtensions ā”€ā”€ v0.9.3
   Installed DiffRules ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ā”€ v1.15.1
  Downloaded artifact: OpenSpecFun
    Updating `~/.julia/environments/v1.10/Project.toml`
  [e1828068] + CCBlade v0.2.5 `~/Desktop/BU Research/CC Blade/CCBlade.jl_master`
    Updating `~/.julia/environments/v1.10/Manifest.toml`
  [e1828068] + CCBlade v0.2.5 `~/Desktop/BU Research/CC Blade/CCBlade.jl_master`
  [d360d2e6] + ChainRulesCore v1.20.0
  [bbf7d656] + CommonSubexpressions v0.3.0
  [34da2185] + Compat v4.12.0
  [163ba53b] + DiffResults v1.1.0
  [b552c78f] + DiffRules v1.15.1
  [ffbed154] + DocStringExtensions v0.9.3
  [6cb5d3fb] + FLOWMath v0.3.3
  [f6369f11] + ForwardDiff v0.10.36
  [069b7b12] + FunctionWrappers v1.1.3
  [e7cbb90b] + ImplicitAD v0.3.1
  [92d709cd] + IrrationalConstants v0.2.2
  [692b3bcd] + JLLWrappers v1.5.0
  [2ab3a3ac] + LogExpFunctions v0.3.26
  [77ba4419] + NaNMath v1.0.2
  [6fe1bfb0] + OffsetArrays v1.13.0
  [37e2e3b7] + ReverseDiff v1.15.1
  [276daf66] + SpecialFunctions v2.3.1
  [90137ffa] + StaticArrays v1.9.1
  [1e83bf80] + StaticArraysCore v1.4.2
  [efe28fd5] + OpenSpecFun_jll v0.5.5+0
  [b77e0a4c] + InteractiveUtils
  [76f85450] + LibGit2
  [56ddb016] + Logging
  [44cfe95a] + Pkg v1.10.0
  [3fa0cd96] + REPL
  [6462fe0b] + Sockets
  [2f01184e] + SparseArrays v1.10.0
  [10745b16] + Statistics v1.10.0
  [a4e569a6] + Tar v1.10.0
  [8dfed614] + Test
  [e37daf67] + LibGit2_jll v1.6.4+0
  [05823500] + OpenLibm_jll v0.8.1+2
  [bea87d4a] + SuiteSparse_jll v7.2.1+1
  [3f19e933] + p7zip_jll v17.4.0+2


Thank you very much again for your help! Much appreciated!

The keystroke sequence would be

] dev "/Users/dblachance/Desktop/BU Research/CC Blade/CCBlade.jl-master"