ERROR: option '--worker' is missing an argument


#1

Hi folks,
I am trying to connect a windows julia session to a linux session using the following:
addprocs([“user@host”], dir=“full path directory structure”, exename=“path to julia executable”)
I am getting the error message

ERROR: option ‘–worker’ is missing an argument

Does anybody know what is causing this or what argument I am missing. Or if anybody has connected windows to linux please do you have any advice.

Thanks in advance,

Noel


#2

I think Windows workers may not be compatible with other workers.


#3

hi @noel_ryan,

I’m not sure if this is your situation, but it might be that Master and Workers run different Julia versions.

I got the same error when trying to connect Docker containers (Master and Workers) in a Linux environment. Master had Julia 0.6.2 and Workers Julia 0.4.7. When I fixed it by setting up the Workers to use the Julia 0.6.2 binary, it worked.

BTW, try to run the following command at the Windows machine (on which I assume the Master process is running):

ssh -i $ssh_key -o "StrictHostKeyChecking no" user@linux-machine-address

If you managed to login, this is not an SSH issue. In this case, it might be that Windows and Linux implementations of transport protocol TCP are not compatible. Master and Workers communicate over TCP. Read here the docs.

Best,

André Lage.