Error message when starting


#1

I have troubles running Julia on my MacOS Siera.

I get the following error message:

~ $ exec ‘/Applications/Julia-0.6.app/Contents/Resources/julia/bin/julia’ fatal: error thrown and no exception handler available. Base.InitError(mod=:LibGit2, error=ErrorException(“could not load library “libgit2” dlopen(libgit2.dylib, 1): Library not loaded: @rpath/libcurl.dylib Referenced from: /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib Reason: Incompatible library version: libgit2.dylib requires version 9.0.0 or later, but libcurl.4.dylib provides version 7.0.0”)) rec_backtrace at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/stackwalk.c:84 record_backtrace at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/task.c:245 [inlined] jl_throw at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/task.c:564 jl_errorf at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/rtutils.c:77 jl_dlerror at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/dlload.c:74 jl_load_dynamic_library_ at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/dlload.c:205 jl_get_library at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/runtime_ccall.cpp:159 jl_load_and_lookup at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/runtime_ccall.cpp:170 jlplt_git_libgit2_init_23686 at /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/sys.dylib (unknown line) init at ./libgit2/libgit2.jl:919 jlcall___init___23681 at /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/sys.dylib (unknown line) jl_apply at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/./julia.h:1424 [inlined] jl_module_run_initializer at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/toplevel.c:87 _julia_init at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/init.c:733 julia_init at /Users/osx/buildbot/slave/package_osx10_9-x64/build/src/task.c:297 main at /Applications/Julia-0.6.app/Contents/Resources/julia/bin/julia (unknown line)

I have posted the issue also here:
https://stackoverflow.com/questions/45647539/julia-troubles-running-macos-siera


#2

Can you post the output of otool -L /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib ?


#3

I get the following Output:
max ~ $ otool -L /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib ?
/Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib:
@rpath/libgit2.dylib (compatibility version 25.0.0, current version 0.25.1)
@rpath/libcurl.dylib (compatibility version 9.0.0, current version 9.0.0)
/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
/System/Library/Frameworks/Security.framework/Versions/A/Security (compatibility version 1.0.0, current version 55471.14.40)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.17.0)
@rpath/libssh2.dylib (compatibility version 1.0.0, current version 1.0.1)
/usr/lib/libiconv.2.dylib (compatibility version 7.0.0, current version 7.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/objdump: ‘?’: No such file or directory

thank you for your help


#4

I get the following output:
max ~ $ otool -L /Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib ?
/Applications/Julia-0.6.app/Contents/Resources/julia/lib/julia/libgit2.dylib:
@rpath/libgit2.dylib (compatibility version 25.0.0, current version 0.25.1)
@rpath/libcurl.dylib (compatibility version 9.0.0, current version 9.0.0)
/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
/System/Library/Frameworks/Security.framework/Versions/A/Security (compatibility version 1.0.0, current version 55471.14.40)
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 855.17.0)
@rpath/libssh2.dylib (compatibility version 1.0.0, current version 1.0.1)
/usr/lib/libiconv.2.dylib (compatibility version 7.0.0, current version 7.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/objdump: ‘?’: No such file or directory

thank you for your help.