ERROR: IOError: could not spawn `C:Program FilesMicrosoft VS CodeCode.exe`


#1

Hello.

I’m using Julia 1.0.3 with VS Code and the plugin 0.11.1 on Windows 10 and
trying to run simple commands from a tutorial.

When I run this:

julia> @edit max(1,2)

I get this error:

ERROR: IOError: could not spawn `C:Program FilesMicrosoft VS CodeCode.exe 'C:\Users\joe\AppData\Local\Julia-1.0.3\bin\..\share\julia\base\promotion.jl'`: no such file or directory (ENOENT)
Stacktrace:
 [1] _jl_spawn(::String, ::Array{String,1}, ::Cmd, ::Tuple{RawFD,RawFD,RawFD}) at .\process.jl:367
 [2] (::getfield(Base, Symbol("##493#494")){Cmd})(::Tuple{RawFD,RawFD,RawFD}) at .\process.jl:509
 [3] setup_stdio(::getfield(Base, Symbol("##493#494")){Cmd}, ::Tuple{RawFD,RawFD,RawFD}) at .\process.jl:490
 [4] #_spawn#492(::Nothing, ::Function, ::Cmd, ::Tuple{RawFD,RawFD,RawFD}) at .\process.jl:508
 [5] _spawn at .\process.jl:504 [inlined]
 [6] #run#503(::Bool, ::Function, ::Cmd) at .\process.jl:662
 [7] run at .\process.jl:661 [inlined]
 [8] edit(::String, ::Int32) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\InteractiveUtils\src\editless.jl:78
 [9] edit(::Function, ::Any) at C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\InteractiveUtils\src\editless.jl:93
 [10] top-level scope at none:0

It seems to be related to the path but it’s strange because Julia is working, if I write other commands they are recognized and work well.

What do I need to do?

My settings say:

Julia: Executable Path
Points to the julia executable.
C:\Users\joe\AppData\Local\Julia-1.0.3\bin\julia.exe

I have also tried unsuccessfully with
C:\\Users\\joe\\AppData\\Local\\Julia-1.0.3\\bin\\julia.exe


#2

That is a bug. Fix is ready. Thanks for reporting!