Error installing (building) Reduce.jl

I am currently wanting to try Reduce.jl for symbolic stuff, but I am unable to build it.

I have tried in different the standalone REPL and VSCode’s integrated terminal with a few hours apart. The attempts were also on seperate networks, one public (school) and one private.

The error message I get is included below. Is anyone else experiencing this, and do anyone know what I can do about it?

Error: Error building `Reduce`: 
│ ┌ Error: Download failed: curl: (7) Failed to connect 
to port 443: Timed out
│ └ @ Base download.jl:43
│ ERROR: LoadError: failed process: Process(`'C:\WINDOWS\System32\curl.exe' -s -S -g -L -f -o 'C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\'`, ProcessExited(7)) [7] 
│ Stacktrace:
│  [1] pipeline_error at .\process.jl:525 [inlined]     
│  [2] download_curl(::String, ::String, ::String) at .\download.jl:44
│  [3] download(::String, ::String) at .\download.jl:62 
│  [4] top-level scope at C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\build.jl:95
│  [5] include(::String) at .\client.jl:457
│  [6] top-level scope at none:5
│ in expression starting at C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\build.jl:30
│ caused by [exception 1]
│ IOError: could not spawn `'C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\reduce.exe' --nogui`: no such file or directory (ENOENT)
│ Stacktrace:
│  [1] _spawn_primitive(::String, ::Cmd, ::Array{Any,1}) at .\process.jl:99
│  [2] #585 at .\process.jl:112 [inlined]
│  [3] setup_stdios(::Base.var"#585#586"{Cmd}, ::Array{Any,1}) at .\process.jl:196
│  [4] _spawn at .\process.jl:111 [inlined]
│  [5] _spawn(::Base.CmdRedirect, ::Array{Any,1}) at .\process.jl:139 (repeats 3 times)
│  [6] run(::Base.CmdRedirect; wait::Bool) at .\process.jl:443
│  [7] _spawn(::Cmd, ::Base.DevNull, ::Base.DevNull) at 
C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\svn.jl:25 (repeats 2 times)
│  [8] top-level scope at C:\Users\MyUser\.julia\packages\Reduce\Ery9E\deps\build.jl:88
│  [9] include(::String) at .\client.jl:457
│  [10] top-level scope at none:5
│ Building Reduce.jl with CSL binaries ...
└ @ Pkg.Operations D:\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.5\Pkg\src\Operations.jl:949
1 Like

3 days later. I have now turned the computer off/on, reinstalled Julia, deleted my .julia folder and tried installing from multiple different programs (REPL, VSCode, both notebooks). I have also tried to download the package content manually and paste it into the right location. Nothing helps.

I always get the timeout from the connection to, which also times out when I open it in a browser.

Any help is very appreciated

1 Like

You should probably open an issue at, as the problem sounds specific to that package.


Right. Still a bit scared to open issues on GitHub, but that does indeed sound the like correct channel. I’ll do that, thanks

Don’t be scared, it’s no different to a forum really. :slight_smile:
In general, its much better to open bug reports on GitHub because you know the package maintainer, and people who use that package will see it (it shows up well in google searchs).
Many package mainainers, myself included are not very active on Discourse and are not expecting to find bugs reported here.

I would much rather someone post a false positive bug report on GitHub where I see it,
than miss a bug that was reported on Discourse because the user wasn’t sure if it was their mistake or a bug.
(plus user mistakes often point to gaps in documentation, or an unituitive API, that is something that should be handled on the issue tracker).

When you are maintaining a lot of packages it is a lot of work keeping up with all the bug reports, but at least having them all in one place (the issue tracker) is better than having to go search.



That worked, thanks a lot :smiley: Reduce is now installed and buildt, and I will just have to familiarize myself with it to make use of it


Dennis Bal

1 Like