Error in CUDA testing in VSCode

I’ve been trying to set up CUDA.jl, and installed it using Pkg.add(“CUDA”). In the Julia command line it works, but in VSCode when I run the tests it throws up the following error:

ERROR: LoadError: LoadError: could not load library "C:[...]\.julia\artifacts\39d2e5fe26ace445875427cbc53b9381b9092987\bin\libLLVMExtra-13.dll"
The specified module could not be found.

The file is there, though, and it works in the command line so is there something more I have to do for VS code to be happy with CUDA?

Thanks for any suggestions!

Edit: I reinstalled Julia and now it works, I don’t know what was wrong initially.

Which version of Julia are you using, and which version of LLVM.jl?

I believe it’s LLVM 13 and Julia 1.6.15

That’s an impossible combination. If you’re using a system LLVM build, that’s unsupported, and you should use the official binaries.

Sorry, I think I misinterpreted something then. I’m using the default LLVM for Julia 1.6.15

There is no Julia 1.6.15. What’s the output of versioninfo()?