Error in "build Special Functions

Hi all, this is a question haunting me for a while. I am using win10 as the admin. I can’t run “build SpecialFunctions” in Julia client. The julia 1.0.4 is indeed run as admin. The error says

I did some google on the first warning and then clicked “Developer Mode” in the setting. It didn’t solve the issue. For the second warning I had no clue what it meant.

Thanks for any suggestion.

The first step is to upgrade Julia to the current stable release (v1.1.1). Then try

pkg> rm SpecialFunctions
pkg> add SpecialFunctions

and without explicitly building it (ignoring any messages for the moment), just see if it works

julia> using SpecialFunctions
julia> besselj0(0.5)
0.9384698072408129

if it does not work, or errors on precompiling, then

pkg> build SpecialFunctions

and try using it as above. If it still does not work, post the precompile errors and the build errors … SpecialFunctions has had issues and updating to Julia v1.1.1 helped me get it working. I don’t know that you will find the same thing happens; it is worth trying.

(you should not need developer mode or admin windows … the message about symlinks can be ignored without difficulty – as far as I know)

Much appreciation for the prompt reply. Unfortunately the same errors reappeared.

Error at precompling SpeicalFunctions:

Error at building SpecialFunctions

ok – I don’t know what to do so I am mentioning your thread on the math channel at Julia’s Slack, someone who reads that will be familiar with this issue – although you may need to wait a while for them to be awake.

One last thing to try

pkg> rm SpecialFunctions
pkg> add SpecialFunctions#master
julia> using SpecialFunctions

(otherwise wait for a more informed response :slight_smile: )

under deps there is a directory usr – delete that directory and try to get SpecialFunctions once again (there is a known issue that this resolves, whether it fixes things for you is to be seen). If that does not work … delete the fvheQ directory and if you have
C:\Users\(your user name).julia\compiled\v1.1\SpecialFunctions
delete that directory too, then try to get Special Functions once again.
After that – I dunno.

Yes, I find several docs under the folder fvheQ

My win10 system is default in Chinese, and I may not change to English in the setting…

please see my last note for directions (that it is in Chinese should make no difference).

Here is a note from Slack:

Cormullion < 1 minute ago
SpecialFunctions is the only package that gives me any problems these days (apart from Cairo.jl :)). It usually fails to install first time, with errors such as

┌ Error: Error building SpecialFunctions:
│ gfortran -m64 -O2 -fPIC -fPIC -c amos/d1mach.f -o amos/d1mach.f.o
│ make: gfortran: No such file or directory
│ make: *** [amos/d1mach.f.o] Error 1
│ [ Info: Downloading https://github.com/JuliaLang/openlibm/archive/v0.5.4.tar.gz to /var/folders/0n/rxl1scks0f19tnxt9pgjcs_40000gp/T/juliaBwbaDX-download.gz…, then you try it again, possibly twice, and it works. Actually the first error does say Please re-run Pkg.build("SpecialFunctions"), and restart Julia. so perhaps it just needs a few attempts.

Hi Jeffrey, thanks a lot for all tips! The issues are still there after several tries. I also encountered the similar issue when building “Arpack” to test package “Distributions”.

So I guess my problem may be not specific to SpecialFunctions that is necessary for me to use JuMP

Both SpecialFunctions and Arpack are known to be troublesome sometimes, particularly with Windows. I do not have a good answer for you :frowning: .
You could try installing this stuff including Julia … .using WindowsTerminal https://www.microsoft.com/en-us/p/windows-terminal-preview/9n0dx20hk701?activetab=pivot:overviewtab (get the dependencies first if you try this)

:slightly_smiling_face:I finally found out a partial solution. What went wrong in precompling and building SpecialFunctions and Arpack seems to me that the powershell prevents Julia from downloading gcc7.tar.gz into the designated folder. I can manually click the link in the warning message and then download them to finish the building process. I hope there will be a permanent answer to fix it. Terminal on windows could be worth a try and I have no problem using Julia in Mac.

Thanks again for your help :+1:

For similar posts, see:
https://discourse.julialang.org/search?q=windows%20admin
The first post there seems to have similar errors, that were (partly) solved.

1 Like

Yes, and I guess the issue sticks with the downloading error, something weird in win10.

Hello there,

I had the similar problems adding and compiling SpecialFunctions, which is quite frustrating as these functions make julia especially appealing.

In my case downloading

https://github.com/JuliaPackaging/Yggdrasil/releases/download/OpenSpecFun-v0.5.3+0/OpenSpecFun.v0.5.3.x86_64-w64-mingw32-gcc7.tar.gz

to

C:\Users\meAsUser.julia\packages\SpecialFunctions\IYceU\deps\usr\downloads\

solved the problem.
Running REPL as admin did not help. When I tried, the download into the admin - user folder failed. I wonder if there is some problem in the SpecialFunctions package setup?

I am using julia-1.2 and windows 7.

(This was my first post in this forum, and I am taking my first steps in julia)

Yes, you are right. You have to download packages manually into designated folder in this case, hope it can be solved in future development.