Dependency build failure and current path

I encounter a recurring error with packages failing to build due to a dependency on Emoji_Entities. That package fails to build with the error “Package JSON not found in current path”. This error has been raised as an issue here.

Adding JSON does not make the error go away. I tried entirely removing ~/.julia and then immediately after starting julia and going to the Pkg interface, add JSON which is successfully installed. Upon add Emoji_Entities the same error recurs:

(@v1.6) pkg> add Emoji_Entities
   Resolving package versions...
   Installed StrTables ────── v1.0.1
   Installed Emoji_Entities ─ v1.0.1
    Updating `~/.julia/environments/v1.6/Project.toml`
  [fd8f23de] + Emoji_Entities v1.0.1
    Updating `~/.julia/environments/v1.6/Manifest.toml`
  [fd8f23de] + Emoji_Entities v1.0.1
  [9700d1a9] + StrTables v1.0.1
    Building Emoji_Entities → `~/.julia/scratchspaces/44cfe95a-1eb2-52ea-b672-e2afdf69b78f/d45cd624dadedf039b74025d6ac4b200100a2e65/build.log`
ERROR: Error building `Emoji_Entities`:
ERROR: LoadError: ArgumentError: Package JSON not found in current path:
- Run `import Pkg; Pkg.add("JSON")` to install the JSON package.

 [1] require(into::Module, mod::Symbol)
   @ Base ./loading.jl:871
 [2] include(fname::String)
   @ Base.MainInclude ./client.jl:444
 [3] top-level scope
   @ none:5
in expression starting at /Users/foo/.julia/packages/Emoji_Entities/qRCWW/deps/build.jl:1

Platform: macOS 10.15.7, julia 1.6

Perhaps this is an issue with my load path. Any suggestions on fixing it?

julia> @show LOAD_PATH
LOAD_PATH = ["@", "@v#.#", "@stdlib"]
3-element Vector{String}:

julia> LOAD_PATH
3-element Vector{String}:

julia> Base.load_path()
2-element Vector{String}:

This seems to have been caused by a change in Julia v1.6.
Previously, even if it couldn’t load the package, the build script continued and then located the pre-built data file (that is already checked in).