CUTENSOR not available

Hi All,
I am trying to install CUDA with CUTENSOR support on a Debian 11+julia 1.8.5, but witout success.
The main problem is that CUTENSOR is non supported at moment for the new CUDA 12.1 drivers.
This is the error message
julia> using cuTENSOR
[ Info: Precompiling cuTENSOR [011b41b2-24ef-40a8-b3eb-fa098493e9e1]
┌ Error: cuTENSOR is not available for your platform (x86_64-linux-gnu-libgfortran5-cxx11-libstdcxx30-cuda+12.1-julia_version+1.8.5)
└ @ cuTENSOR ~/.julia/packages/cuTENSOR/WTpqy/src/cuTENSOR.jl:99

Is there any workaround for this?


How about installing a lower version of the CUDA software?
In the HPC systems I install you can have multiple versions of CUDA. You select which one you work with using Modules files.

The lowest one I can install without recomiling everything from scratch is 11.5, which still wouldn’t be supported.

Before 11.1 Debian was not officially supported and I cannot change Linux distro.

You can have CUDA.jl use an older toolkit using CUDA.set_runtime_version!; if you use e.g. v"11.8" you should be able to use CUTENSOR again. (Admittedly, the error reporting still need to be improved, but these changes are fairly recent.)

I tried CUDA.set_runtime_version!(v"11.8") and (v"11.0") and in both cases CUDA recomplies succesfully but CUTENSOR is not loaded. In the REPL if I run suing CUDA.CUTENSOR then I get:
ERROR: UndefVarError: CUTENSOR not defined

This is the output of CUDA.versioninfo():

CUDA runtime 11.0, artifact installation
CUDA driver 12.1
NVIDIA driver 530.30.2


  • CUBLAS: 11.2.0
  • CURAND: 10.2.1
  • CUFFT: 10.2.1
  • CUSOLVER: 10.6.0
  • CUSPARSE: 11.1.1
  • CUPTI: 13.0.0
  • NVML: 12.0.0+530.30.2


  • Julia: 1.8.5
  • LLVM: 13.0.1
  • PTX ISA support: 3.2, 4.0, 4.1, 4.2, 4.3, 5.0, 6.0, 6.1, 6.3, 6.4, 6.5, 7.0
  • Device capability support: sm_37, sm_50, sm_52, sm_53, sm_60, sm_61, sm_62, sm_70, sm_72, sm_75, sm_80

1 device:
0: NVIDIA A40 (sm_86, 44.398 GiB / 44.988 GiB available)

As you see CUTENSOR is not loaded.

CUTENSOR will never be listed in the versioninfo output nowadays since it’s part of an external package.

Indeed the command Pkg.test(“cuTENSOR”) is succesful

Although the tests for CUDA itself fails.