CUDA verbose mode off

Hi folks,

sometimes I find that my CUDA functions display this message

┌ Warning: Performing scalar operations on GPU arrays: This is very slow, consider disallowing these operations with `allowscalar(false)`
└ @ GPUArrays ~/.julia/packages/GPUArrays/1wgPO/src/indexing.jl:16

due to the fact that at some (minor) point I’m forced to do a scalar operator, not in parallel. While I know this happens, the appearance of the message is somewhat a pain, so I was wondering if there is a way to turn off the message itself…



You can wrap that code in @allowscalar. The warning will be gone on GPUArrays#master.