CSV doesn't compile Julia 1.7.2

I have tried several different methods of getting CSV to compile. I have followed the complete wipe instructions and I am still encountering the same problem. I have a Dell XPS 17 9710 running Windows 11. The log follows.
julia> import Pkg; Pkg.precompile()
Precompiling project…
✗ CSV
0 dependencies successfully precompiled in 3 seconds (20 already precompiled)

ERROR: The following 1 direct dependency failed to precompile:

CSV [336ed68f-0bac-5ca0-87d4-7b16caf5d00b]

Failed to precompile CSV [336ed68f-0bac-5ca0-87d4-7b16caf5d00b] to C:\Users\scott.julia\compiled\v1.7\CSV\jl_A145.tmp.
Stacktrace:
[1] pkgerror(msg::String)
@ Pkg.Types C:\Users\scott\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\Types.jl:68
[2] precompile(ctx::Pkg.Types.Context; internal_call::Bool, strict::Bool, warn_loaded::Bool, already_instantiated::Bool, kwargs::Base.Pairs{Symbol, Union{}, Tuple{}, NamedTuple{(), Tuple{}}})
@ Pkg.API C:\Users\scott\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1362
[3] precompile
@ C:\Users\scott\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1013 [inlined]
[4] #precompile#220
@ C:\Users\scott\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1011 [inlined]
[5] precompile()
@ Pkg.API C:\Users\scott\AppData\Local\Programs\Julia-1.7.2\share\julia\stdlib\v1.7\Pkg\src\API.jl:1011
[6] top-level scope
@ REPL[2]:1

Many people have the same issue

I heard many stories from

Try ]build CSV to keep using CSV until it works

I tried that but when I type using CSV the same precompile error happens.

what does

]st -m

say?

Here is the output.

(@v1.7) pkg> st -m
Status C:\Users\scott\.julia\environments\v1.7\Manifest.toml
[336ed68f] CSV v0.10.2
[944b1d66] CodecZlib v0.7.0
[34da2185] Compat v3.41.0
[a8cc5b0e] Crayons v4.1.1
[9a962f9c] DataAPI v1.9.0
[a93c6f00] DataFrames v1.3.2
[864edb3b] DataStructures v0.18.11
[e2d170a0] DataValueInterfaces v1.0.0
[48062228] FilePathsBase v0.9.17
[59287772] Formatting v0.4.2
[842dd82b] InlineStrings v1.1.2
[41ab1584] InvertedIndices v1.1.0
[82899510] IteratorInterfaceExtensions v1.0.0
[e1d29d7a] Missings v1.0.2
[bac558e1] OrderedCollections v1.4.1
[69de0a69] Parsers v2.2.2
[2dfb63ee] PooledArrays v1.4.0
[08abe8d2] PrettyTables v1.3.1
[189a3867] Reexport v1.2.2
[91c51154] SentinelArrays v1.3.12
[a2af1166] SortingAlgorithms v1.0.1
[3783bdb8] TableTraits v1.0.1
[bd369af6] Tables v1.6.1
[3bb67fe8] TranscodingStreams v0.9.6
[ea10d353] WeakRefStrings v1.4.1
[0dad84c5] ArgTools
[56f22d72] Artifacts
[2a0f44e3] Base64
[ade2ca70] Dates
[8bb1440f] DelimitedFiles
[8ba89e20] Distributed
[f43a241f] Downloads
[9fa8497b] Future
[b77e0a4c] InteractiveUtils
[b27032c2] LibCURL
[76f85450] LibGit2
[8f399da3] Libdl
[37e2e46d] LinearAlgebra
[56ddb016] Logging
[d6f4376e] Markdown
[a63ad114] Mmap
[ca575930] NetworkOptions
[44cfe95a] Pkg
[de0858da] Printf
[3fa0cd96] REPL
[9a3f8284] Random
[ea8e919c] SHA
[9e88b42a] Serialization
[1a1011a3] SharedArrays
[6462fe0b] Sockets
[2f01184e] SparseArrays
[10745b16] Statistics
[fa267f1f] TOML
[a4e569a6] Tar
[8dfed614] Test
[cf7118a7] UUIDs
[4ec0a83e] Unicode
[e66e0078] CompilerSupportLibraries_jll
[deac9b47] LibCURL_jll
[29816b5a] LibSSH2_jll
[c8ffd9c3] MbedTLS_jll
[14a3606d] MozillaCACerts_jll
[4536629a] OpenBLAS_jll
[83775a58] Zlib_jll
[8e850b90] libblastrampoline_jll
[8e850ede] nghttp2_jll
[3f19e933] p7zip_jll

This is

1 Like

I don’t know if this is helpful, but I can confirm that CSV .10.2 works with Julia 1.7.2 on Ubuntu 20.04.