Cplex turn logging off

Hello, I am using CPLEX solver and I would like to silence the output. I know with Gurobi you set OutputFlag=0 as in the following. Does anyone know?

m=Model(with_optimizer(Gurobi.Optimizer,OutputFlag=0))

I think it’s CPX_PARAM_SCRIND=false for CPLEX instead of OutputFlag=0. I don’t remember how I found that, but it’s what I have in some code from awhile ago.

thanks :slight_smile:

Note that I recently re-wrote the CPLEX wrapper for JuMP. We’re just waiting on a tag. (It won’t work right now.)

Once the new version is released, you will be able to go:

model = Model(with_optimizer(CPLEX.Optimizer))
MOI.set(model, MOI.Silent(), true)

For other options, see the README:

1 Like