Conventional name for an optional workspace keyword argument

I have a function sort! that operates out of place and accepts an optional workspace vector as a keyword argument for performance reasons. Is there a conventional name for this argument?

y = similar(first(x))
for xi in x
    sort!(xi; name=y)

What should name be?

(cross-posted: Add workspace support to sorting by LilithHafner · Pull Request #45330 · JuliaLang/julia · GitHub)

I usually think of a “cache” as being a cache of values, rather than a location with empty available memory.

Perhaps “workspace” or “buffer” works better.


LAPACK, for example, uses “WORK”, so I think something similar to “workspace” may be a good idea

1 Like