Compiling Julia from source


#1

As the title suggests, I am trying to compile Julia (v0.6.2) from source (to enable MKL support)
Unfortunately, I get the following error:

curl: (7) Failed to connect to ftp.csx.cam.ac.uk port 443:Connection refused

Did anyone encounter something similar?


#2

What OS are you using?


#3

Tamas_Papp asks the correct question. ftp.csx.cam.ac.uk seems to be down. I suspect this is a rather old machine, which is no longer in use.


#4

#5

Thaks for your reply. It is a Linux machine.


#6

Ay caramba… over on a mailing list not a million miles away I was arguing that in the context of offering Redhat, SuSE or Ubuntu to users who are used to Ubuntu that ‘linux is linux is linux’.
And here I am, hoist by my own petard. Karma is a bitch etc.

Snir, you of course are corect to reply linux. You could get the ‘flavour’ by cat /etc/elease
and the kernel version by uname -r


#7

I got exactly the same error a couple of days ago.
I’m using Debian GNU/Linux 9 (stretch).


#8

I’m getting the same error here. (I’m using Manjaro Linux…)


#9

Kristoffer’s answer is correct — this is simply an outdated URL in our build system. It’s been backported and will be fixed in any subsequent 0.6.x patch releases, but in the meantime you can download the full tarball which already bundles these dependencies for you:

https://github.com/JuliaLang/julia/releases/download/v0.6.2/julia-0.6.2-full.tar.gz


#10

As a dirty workaround – you can manually apply the following change:

worked for me.