Compat bounds for "extras"

Is there a way to add compat bounds for packages required only by the tests? I seem to remember a discussion about this a while back but can’t put my hand on it anymore.

Edit: ah it might be Proposal for first class support of conditional dependencies in Pkg · Issue #1285 · JuliaLang/Pkg.jl · GitHub ; anyone has updates on that?

Yeah just put them in the same [compat] section.

3 Likes