Chemfiles -- contains

Hello dear all,

I tried to install Chemfiles.jl. During the test:

julia> Pkg.test("Chemfiles")

I obtained an error:

Test Summary: | Pass  Total
Generics      |    1      1
Test Summary: | Pass  Total
Atom          |   16     16
WARNING: both Chemfiles and Base export "contains"; uses of it in module Main must be qualified
Residue: Error During Test at /home/aquarelle/.julia/packages/Chemfiles/uJPdJ/test/Residue.jl:22
  Test threw exception
  Expression: contains(residue, 56) == true
  UndefVarError: contains not defined
   [1] top-level scope at /home/aquarelle/.julia/packages/Chemfiles/uJPdJ/test/Residue.jl:22
   [2] top-level scope at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.5/Test/src/Test.jl:1115
   [3] top-level scope at /home/aquarelle/.julia/packages/Chemfiles/uJPdJ/test/Residue.jl:2
Test Summary: | Pass  Error  Total
Residue       |   12      1     13
ERROR: LoadError: LoadError: Some tests did not pass: 12 passed, 0 failed, 1 errored, 0 broken.
in expression starting at /home/aquarelle/.julia/packages/Chemfiles/uJPdJ/test/Residue.jl:1
in expression starting at /home/aquarelle/.julia/packages/Chemfiles/uJPdJ/test/runtests.jl:28
ERROR: Package Chemfiles errored during testing

I tried to substitute “contains” by “occursin” (with the permutation of arguments) but it doesn’t work.
Any ideas?

To avoid the error use:

If it is a good idea to keep that name or not is up to the developers. Maybe it is a good idea to file an issue. (to avoid that error they have to explicitly import contains from base in their module, before overloading it).

Many thanks leandromartinez98. :wink:
Indeed I am going to file an issue.