Can't open Julia Repl on Linux HPC server

Hi! I wish to install Julia on a HPC server locally on my folder.I downloaded the tar file & tried to run the ./julia that is in the bin directory inside julia-1.8.0 . I get a prompt like this.
julia_error

It remain stuck there forever. I can execute scripts by running julia script but the interactive environment is not working. I need that to install some required packages.

Here are some system details.

NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

Info regarding CPU.

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                40
On-line CPU(s) list:   0-39
Thread(s) per core:    1
Core(s) per socket:    20
Socket(s):             2
NUMA node(s):          2
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 85
Model name:            Intel(R) Xeon(R) Gold 6248 CPU @ 2.50GHz
Stepping:              7
CPU MHz:               2501.000
CPU max MHz:           2501.0000
CPU min MHz:           1000.0000
BogoMIPS:              5000.00
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              1024K
L3 cache:              28160K
NUMA node0 CPU(s):     0-19
NUMA node1 CPU(s):     20-39
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch epb cat_l3 cdp_l3 intel_ppin intel_pt ssbd mba ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm cqm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb avx512cd avx512bw avx512vl xsaveopt xsavec xgetbv1 cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts pku ospke avx512_vnni spec_ctrl intel_stibp flush_l1d arch_capabilities


I have used local installation of Julia before on another server & it worked flawlessly. I don’t have any idea what is going wrong here.

Any suggestion would be of great help.

Have you tried running the REPL on one of the compute nodes, with an interactive job?

srun -ntasks 1 --cpus-per-task 1 -p PARTITION -t 10:00 --pty bash -i

Adding any other required flags. From this terminal, try and run the julia binary.

EDIT: Assuming your HPC uses a SLURM scheduler. I am sure there are equivalent ways of scheduling on other schedulers.

Hi! Thanks for the quick response.

I tried srun --pty julia that gave me the same REPL as above where the prompt gets stuk at that position.

I also tried

 srun --nodes=1 --ntasks-per-node=1 --time=01:00:00  julia

This remains stuck after Job allocation.
But it seems like I can execute scripts by running julia script.jl
Is it possible to install Packages using a script? I tried to have a script like below

println("Testing Julia")

using Pkg
Pkg.add("MKL")
Pkg.add("ExportAll")
Pkg.add("Plots")

but it shows,

Testing Julia
ERROR: ERROR: fatal: error thrown and no exception handler available.
ErrorException("`ccall` requires the compiler")
copy at array.jl:369
IdDict at iddict.jl:45
copy at iddict.jl:153
#show_full_backtrace#881 at errorshow.jl:580
show_full_backtrace##kw at errorshow.jl:576
show_backtrace at errorshow.jl:781
#showerror#860 at errorshow.jl:90
showerror##kw at errorshow.jl:86
show_exception_stack at errorshow.jl:878
display_error at client.jl:103
srun: error: cn005: task 0: Exited with exit code 1

Sounds like Julia 1.8.0 hangs on startup when LD_LIBRARY_PATH is set · Issue #46409 · JuliaLang/julia · GitHub, which should be fixed by Consistently use `RUNPATH` in our libraries by staticfloat · Pull Request #46464 · JuliaLang/julia · GitHub. Temporary workaround is to start Julia with

LD_LIBRARY_PATH="" julia
2 Likes

Can’t thank you enough. This solved it & from github it looks like an issue with 1.8 version.
Just another small question if you don’t mind, should I write the LD_LIBRARY_PATH="" julia in Slurm scripts also when I submit the jobs?

Yes, as long as you don’t need libraries outside those installed for you by Julia that should be fine.

1 Like