Cannot install the up-to-date version despite that all requirements satisfied

Hi everyone,

I wanted to install a package called Isosuite (find it here https://github.com/algorithmx/Isosuite) , which has now been updated to v0.2.6. However, when I tried to install it on an HPC, julia insists to install v0.1.2. I’ve been burning in hell for the entire afternoon without an effective solution. In other places (my laptop and another HPC) it works just fine.

Does anybody know what could be the problem and kindly help me to proceed? I spend quite a long time in dealing with such a version problem …

Here is an exerpt of the output during installation:

(@v1.5) pkg> st PyCall
Status ~/.julia/environments/v1.5/Project.toml
[438e738f] PyCall v1.92.1

(@v1.5) pkg> add Isosuite
Updating registry at ~/.julia/registries/General
Resolving package versions…
Updating ~/.julia/environments/v1.5/Project.toml
[4e0cf86c] + Isosuite v0.1.2
Updating ~/.julia/environments/v1.5/Manifest.toml
[4e0cf86c] + Isosuite v0.1.2

(@v1.5) pkg> add Isosuite@0.2.6
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package Isosuite [4e0cf86c]:
Isosuite [4e0cf86c] log:
├─possible versions are: 0.1.0-0.1.2 or uninstalled
└─restricted to versions 0.2.6 by an explicit requirement — no versions left

The Project.toml file of Isosuite reads

name = “Isosuite”
uuid = “4e0cf86c-8ca5-4e68-a38e-9d6c92424124”
authors = [“Yunlong Lian algorithm.lian@gmail.com”]
version = “0.2.6”

[deps]
LinearAlgebra = “37e2e46d-f89d-539d-b4ee-838fcccc9c8e”
Printf = “de0858da-6303-5e67-8744-51eddeeeb8d7”
PyCall = “438e738f-606a-5dbb-bf0a-cddfbfd45ab0”

[compat]
julia = “1”
PyCall = “1.0,3.0”

I can’t see which requirement is not satisfied …

Note, I add similar problem (on Linux) for upgrading , on Plots, during half of day last Saturday (Nov 21st).

When I started to investigate, I found that in fact the update if the registry gor me with old entry’s : going to .Julia/registries/General /Plots/, and doing cat Versions.toml I saw last referenced version 1.7.1 whence I know it is 1.9.1.

Then I got all kind of unresolved references. It seems to me the registry was bad’ but a reinstall got me exactly similar invalid Plots versions in General. I check on other Linuxes that got updated the day before that that had indeed Plots versions to 1.9.1

In despair, I elected to wait some time and see if it was permanent or transitory. On Sunday a new ]up got me a correct General and all then since works.

I suspect the the European server for pkg.Julia Lang.org served me (incorrectly) an old registry version, is that really possible ?

4 Likes

thanks!

Problem solved. I changed the environment variable JULIA_PKG_SERVER from default to a mirror (inside China) and then got the correct version. For Julia users in China, I am actually setting
ENV[“JULIA_PKG_SERVER”]=“https://mirrors.tuna.tsinghua.edu.cn/julia

That HPC administrator has put stupid restrictions to the internet access. Apparently there is a lag between the default pkg server (I am unable to guess what it is) and the mirror. The sysadmin is so afraid of users abusing their internet connection, for obvious reasons.

1 Like

Happy if I could be of some help. Enjoy Julia on HPC then !

1 Like