Can pyplot scatterplots take values smaller than 1e-16?

When running the following code,

using Plots
x = exp.(randn(100) .- 36)
y = exp.(randn(100) .- 36)
plot(x,y, xscale = :log10, yscale = :log10, markershape = :square)

The lines show perfectly, but funnily enough, the markers are truncated at 1e-16. The same behavior happens for scatter. Fixing this would make me very happy. Using Julia 1.5.0 on Windows 10.


Works fine for me with Plots 1.6.0, Julia 1.5.0 on Windows 10. Perhaps you have an older version?

Thanks for the quick reply. I’ve realized that I had Plots 1.5.8 and PyPlot 2.9.0. I upgraded to Plots 1.6.0, but no change occurred, and no amount of extra upgrading seemed to help. However, I just tried on another computer (which still has Plots 1.5.8 and PyPlot 2.9.0) and the bug isn’t there for some reason. So problem solved for me for now, but still mystery as to what causes this on computer no 1.

If the problem is only in the PyPlot backend, maybe it is somehow related to matplotlib version?

You could try using Conda; Conda.update() to update Matplotlib (assuming it was installed via Conda).

I updated Conda this morning and that did the trick. Indeed the problem seemed with matplotlib. Thanks again for the quick help.