Can a Pkg.checkout be REQUIRED?


#1

I have a package, ArbFloats, that depends upon the presence of Nemo. The current release version of Nemo does not work with v0.6xx. The current checkout version does. How do I get that built first?


#2

#3

ok – is there no way to accomplish this without REQUIRE using a build script?


#4

You can but you shouldn’t. It’s fragile to require a master branch and @tkelman likely won’t accept a release that requires master on another package. Just get them (help them) release the next version instead.


#5

Right; instead of requesting the master branch it’s better to request a specific commit. IIRC that is coming in Pkg3.