AttributeError("module 'geopandas' has no attribute 'plotting'")

I had some problems when using geopandas in julia. First, I run the following code to install the package:
import Pkg; Pkg.add(“CondaPkg”)
using CondaPkg
CondaPkg.add(“geopandas”) .
See How to install geopandas in julia - #4 by M-PERSIC?

It was installed successfuly.

However, when I ran “import geopandas”, the error said geopandas not found. What should I do to deal with it ?

Second, when I create a moule in which geopandas is used, there is an error of AttributeError(“module ‘geopandas’ has no attribute ‘plotting’”). So I checked the geopandas folder , but it did have a file.

I am new to julia, and didn’t find ways to solve these problems. I’ll appreciate it much if someone else can help me out.

How is this different from your other thread here?

Please don’t double post.

If you install a python package with Conda and is it is not available afterwards you might have multiple python installations and aren’t installing packages where you think you are.

I am sorry to double post it, and thanks for your reply. I checked my python versions, and found that there are two place have python.exe, but only one version of python. Shoud I delete one of them? If so, which one should I delete? Or how can I insatall geopandas to the one I wanted to in julia?