Artifact from file rather than url

Hi all,

Trying to add OhMyREPL in my Windows setup at work fails because of artifact fzf.

After some investigation, it turned out my company firewall blocks anything binary. Proxy environment variables are properly configured. I can install packages as long as it doesn’t involve binaries. For example add DataFrames worked.

I could see the link to the fzf artifact download on ~/.julia/packages/fzf_jll/d3VUe/Artifacts.toml:
From a browser I could see that it was blocked by the company firewall

I’m allowed to download the source code though

Is there a way to use the source version of the artifact somehow? For example altering the Artifacts.toml such that it points to the source tarball on disk?

I couldn’t see a way to do it here
and searched the forum a bit before posting - apologies in advance if this has been treated before, no one likes duplicates :slight_smile:

I had the answer right there :upside_down_face:

For anyone having this issue with firewall not allowing binaries, I solved this by altering the Artifacts.toml file providing the url of the source tarball instead (and updating the expected sha256 as well)