Add CUDA adds v0.1

I just moved from the deprecated CuArrays package to CUDA. I used add CUDA and status tells me v0.1 is installed. The most recent release is v1.1.0.

Am I doing something wrong ? Maybe I have to uninstall stuff before ?

What version of Julia are you using? I think CUDA.jl requires Julia v1.3 or later versions

1.4.2

If you do add CUDA@1.1.0 it should tell you the conflict preventing the upgrade (granted it can sometimes be hard to decipher).

Maybe this may be of some help

(DRL_SIP) pkg> status
Status `C:\Users\Henri\OneDrive - UCL\Doctorat\DRL_SIP\Project.toml`
  [fbb218c0] BSON v0.2.6
  [ad839575] Blink v0.12.3
  [336ed68f] CSV v0.7.3
  [052768ef] CUDA v0.1.0
  [c5f51814] CUDAdrv v6.3.0
  [be33ccc6] CUDAnative v3.0.4
  [861a8166] Combinatorics v1.0.2
  [3a865a2d] CuArrays v2.2.2
  [a93c6f00] DataFrames v0.21.4
  [31c24e10] Distributions v0.23.4
  [634d3b9d] DrWatson v1.14.4
  [587475ba] Flux v0.10.4
  [93e5fe13] Hyperopt v0.3.3
  [09f84164] HypothesisTests v0.10.0
  [c601a237] Interact v0.10.3
  [be94c240] InventoryModels v0.1.0 [`src\InventoryModels`]
  [b964fa9f] LaTeXStrings v1.1.0
  [d96e819e] Parameters v0.12.1
  [f27b6e38] Polynomials v1.1.3
  [92933f4c] ProgressMeter v1.3.2
  [d330b81b] PyPlot v2.9.0
  [1a8c2f83] Query v0.12.2
  [189a3867] Reexport v0.2.0
  [276daf66] SpecialFunctions v0.10.3
  [2913bbd2] StatsBase v0.33.0
  [f3b207a7] StatsPlots v0.14.6
  [e88e6eb3] Zygote v0.4.22
  [37e2e46d] LinearAlgebra

ok let me try

Ha, it tells me this

ERROR: Unsatisfiable requirements detected for package Adapt [79e6a3ab]:
 Adapt [79e6a3ab] log:
 ├─possible versions are: [0.3.0-0.3.1, 0.4.0-0.4.2, 1.0.0-1.0.1, 1.1.0, 2.0.0-2.0.2] or uninstalled
 ├─restricted by compatibility requirements with Flux [587475ba] to versions: [0.3.0-0.3.1, 0.4.0-0.4.2, 1.0.0-1.0.1, 1.1.0, 2.0.0-2.0.2]
 │ └─Flux [587475ba] log:
 │   ├─possible versions are: [0.4.1, 0.5.0-0.5.4, 0.6.0-0.6.10, 0.7.0-0.7.3, 0.8.0-0.8.3, 0.9.0, 0.10.0-0.10.4, 0.11.0] or uninstalled
 │   └─restricted to versions * by an explicit requirement, leaving only versions [0.4.1, 0.5.0-0.5.4, 0.6.0-0.6.10, 0.7.0-0.7.3, 0.8.0-0.8.3, 0.9.0, 0.10.0-0.10.4, 0.11.0]
 ├─restricted by compatibility requirements with CuArrays [3a865a2d] to versions: [0.3.0-0.3.1, 0.4.0-0.4.2, 1.0.0-1.0.1, 1.1.0]
 │ └─CuArrays [3a865a2d] log:
 │   ├─possible versions are: [0.2.1, 0.3.0, 0.4.0, 0.5.0, 0.6.0-0.6.2, 0.7.0-0.7.3, 0.8.0-0.8.1, 0.9.0-0.9.1, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0, 1.4.0-1.4.7, 1.5.0, 1.6.0, 1.7.0-1.7.3, 2.0.0-2.0.1, 2.1.0, 2.2.0-2.2.2] or uninstalled
 │   ├─restricted to versions * by an explicit requirement, leaving only versions [0.2.1, 0.3.0, 0.4.0, 0.5.0, 0.6.0-0.6.2, 0.7.0-0.7.3, 0.8.0-0.8.1, 0.9.0-0.9.1, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0, 1.4.0-1.4.7, 1.5.0, 1.6.0, 1.7.0-1.7.3, 2.0.0-2.0.1, 2.1.0, 2.2.0-2.2.2]
 │   └─restricted by compatibility requirements with CUDAdrv [c5f51814] to versions: [0.4.0, 0.5.0, 0.6.0-0.6.2, 0.7.0-0.7.3, 0.8.0-0.8.1, 0.9.0-0.9.1, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0, 1.4.0-1.4.7, 1.5.0, 1.6.0, 1.7.0-1.7.3, 2.0.0-2.0.1, 2.1.0, 2.2.0-2.2.2] or uninstalled, leaving only versions: [0.4.0, 0.5.0, 0.6.0-0.6.2, 0.7.0-0.7.3, 0.8.0-0.8.1, 0.9.0-0.9.1, 1.0.0-1.0.2, 1.1.0, 1.2.0-1.2.1, 1.3.0, 1.4.0-1.4.7, 1.5.0, 1.6.0, 1.7.0-1.7.3, 2.0.0-2.0.1, 2.1.0, 2.2.0-2.2.2]
 │     └─CUDAdrv [c5f51814] log:
 │       ├─possible versions are: [0.8.0-0.8.6, 0.9.0, 1.0.0-1.0.1, 2.0.0, 3.0.0-3.0.1, 3.1.0, 4.0.0-4.0.4, 5.0.0-5.0.1, 5.1.0, 6.0.0-6.0.1, 6.1.0, 6.2.0-6.2.3, 6.3.0] or uninstalled
 │       ├─restricted to versions * by an explicit requirement, leaving only versions [0.8.0-0.8.6, 0.9.0, 1.0.0-1.0.1, 2.0.0, 3.0.0-3.0.1, 3.1.0, 4.0.0-4.0.4, 5.0.0-5.0.1, 5.1.0, 6.0.0-6.0.1, 6.1.0, 6.2.0-6.2.3, 6.3.0]  
 │       └─restricted by compatibility requirements with CuArrays [3a865a2d] to versions: [0.8.0-0.8.6, 1.0.1, 2.0.0, 3.0.0-3.0.1, 3.1.0, 4.0.1-4.0.4, 5.0.0-5.0.1, 5.1.0, 6.0.0-6.0.1, 6.1.0, 6.2.0-6.2.3, 6.3.0]
 │         └─CuArrays [3a865a2d] log: see above
 └─restricted by compatibility requirements with CUDA [052768ef] to versions: 2.0.0-2.0.2 — no versions left
   └─CUDA [052768ef] log:
     ├─possible versions are: [0.1.0, 1.0.0-1.0.2, 1.1.0] or uninstalled
     └─restricted to versions 1.1.0 by an explicit requirement, leaving only versions 1.1.0

So it’s a compatibility issue

As a general recommendation: use local environments for your projects and keep as few packages as possible in the global environment. This will drastically reduce the rate of these issues (and using local environments is a good thing for reproducibility anyway). It’s just impossible to install all packages you may want in a single huge environment without running into compatibility issues.

If you don’t want to follow the above recommendation, try at least to remove non-important packages and update the registry, to relax some constraints

1 Like

Okay, removing CUDAdrv, CUDAnative and CuArrays was necessary. Now everything seems to be in order.

Thank you for your help

I don’t understand, this list I posted is from my project environment. I have almost no package in my global environment I think. Is that a problem you think ? I want people to be able to reproduce the experiments using instantiate.

Oh, ok, didn’t notice this was a local project, than it’s all good :slight_smile: