1.8.0rc4 not compiling on chromebook/Linux

I’m able to build and test julia 1.7.3 on my chromebook (linux / ubuntu) (x86 core M3)

However, I’ve tried building 1.8.3rc4 a couple of times, and I keep getting this error (and make cleanall does not help).

thoughts? thanks

perrin meyer

Generating REPL precompile statements... 40/40
Executing precompile statements... 1973/2016
Precompilation complete. Summary:
Total ─────── 205.231782 seconds
Generation ── 150.375546 seconds 73.2711%
Execution ───  54.856236 seconds 26.7289%
*** This error is usually fixed by running `make clean`. If the error persists, try `make cleanall`. ***
make[1]: *** [sysimage.mk:89: /home/perrinmeyer/julia180rc4/usr/lib/julia/sys-o.a] Error 1
make: *** [Makefile:88: julia-sysimg-release] Error 2

are you running out of ram?

I watched it compiling with htop and the memory usage did not spike (3.7MB used out of 2.74GB available in linux container) but it still is killed at same spot.

is there a better linux command line util to watch memory usage during compiling?


perrin meyer

I don’t think 2.7 GB RAM is sufficient to compile Julia…

You can try give it (more) swap space.

v1.7.3 compiled fine (I tried twice just to make sure), but twice 1.8.0-rc4 failed, which Is why I’m slightly confused, but 1.7 might just be on the edge, and 1.8 then fails…

could a linux guru perhaps give me the magic incantation to increase swap space?