Unsatisfiable requirements detected. And now?


#1

I want to install Nemo. What I did:

(JuliaPro_v1.0.1.1) pkg> add https://github.com/Nemocas/Nemo.jl
  Updating git-repo `https://github.com/Nemocas/Nemo.jl`
[ Info: Assigning UUID c7f49eef-4a2b-5356-a7f4-6c8886feae06 to Nemo
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package AbstractAlgebra [47ef31e3]:
 AbstractAlgebra [47ef31e3] log:
 ├─AbstractAlgebra [47ef31e3] has no known versions!
 └─restricted to versions 0.1.3-* by Nemo [c7f49eef] — no versions left
   └─Nemo [c7f49eef] log:
     ├─possible versions are: 0.0.0 or uninstalled
     └─Nemo [c7f49eef] is fixed to version 0.0.0

And now? What can I do?

─AbstractAlgebra [47ef31e3] has no known versions!
“… is pretty clear, no?”

Not at all!

“You are trying to install Package XYZ I can find no version
of this package which is compatible with the version of Julia
which you are using.”

OK, so I looked at: https://travis-ci.org/Nemocas/Nemo.jl
and I see that it does work with Julia 1. And the same
is true for AbstractAlgebra.

Being clueless …


#2

This is a JuliaPro issue:

Your best bet for now is to either manually clone the General Registry into your .julia/registries folder, or download Julia from julialang.org.


#3

Thanks, this worked!