Pkg error in julia:latest Docker image

I’m having a problem with the julia:latest docker image. Upon attempting to build upon it, I get:

# output omitted 
Installed MbedTLS ───────────────────── v0.6.8
 Installed IteratorInterfaceExtensions ─ v1.0.0
ERROR: type Nothing has no field name
Stacktrace:
 [1] getproperty(::Any, ::Symbol) at ./sysimg.jl:18
 [2] #build_versions#48(::Bool, ::Bool, ::Function, ::Pkg.Types.Context, ::Array{Base.UUID,1}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Operations.jl:1023
 [3] build_versions at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/Operations.jl:1012 [inlined]
 [4] #instantiate#65(::Nothing, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:468
 [5] instantiate at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:437 [inlined]
 [6] do_instantiate!(::Dict{Symbol,Any}, ::Array{String,1}, ::Dict{Symbol,Any}) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/REPLMode.jl:621
 [7] #invokelatest#1(::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Any, ::Any, ::Vararg{Any,N} where N) at ./essentials.jl:742
 [8] invokelatest(::Any, ::Any, ::Vararg{Any,N} where N) at ./essentials.jl:741
 [9] do_cmd!(::Pkg.REPLMode.PkgCommand, ::Pkg.REPLMode.MiniREPL) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/REPLMode.jl:561
 [10] #do_cmd#30(::Bool, ::Function, ::Pkg.REPLMode.MiniREPL, ::String) at /buildworker/worker/package_linux64/build/usr/share/julia/stdlib/v1.1/Pkg/src/REPLMode.jl:536
 [11] (::getfield(Pkg.REPLMode, Symbol("#kw##do_cmd")))(::NamedTuple{(:do_rethrow,),Tuple{Bool}}, ::typeof(Pkg.REPLMode.do_cmd), ::Pkg.REPLMode.MiniREPL, ::String) at ./none:0
 [12] top-level scope at none:0
The command '/bin/sh -c julia -e "using Pkg; pkg\"activate . \"; pkg\"instantiate\"; "' returned a non-zero code: 1

This is the Dockerfile:

FROM julia:latest
RUN apt-get update && apt-get install -y supervisor && apt-get install htop
RUN mkdir -p /var/log/supervisor
COPY supervisord.conf /etc/supervisor/conf.d/supervisord.conf
COPY . /app
WORKDIR /app
RUN julia -e "using Pkg; pkg\"activate . \"; pkg\"instantiate\"; "
EXPOSE 8000
CMD ["/usr/bin/supervisord"]

Do you have a copy of the Project.toml and Manifest.toml files that you are running instantiate on?

Thank you - here they are:


Oops, it might be because two of the packages are deved :-/

OK, yes, that’s it, sorry for the false alarm. It would be useful to throw a clear error if possible. Maybe something in the line of “Dev package Genie can not be found”.

I’m pretty sure we have a better error for that failure mode now.

1 Like