JuliaDB with Parallel Procs Not Working in JuliaPro

I figured something out here. I uninstalled everything (and deleted all Julia remnant folders) and installed only the Julia 1.0.4 console (rather than JuliaPro). The code works.

Maybe JuliaPro isn’t working right for what I am trying to do, or maybe my installation/configuration is faulty.

When I installed JuliaPro, the default folder path is too long, so I have to change it to something shorter. I am guessing I need to set some kind of home folder path variable somewhere, but I don’t know what to configure after the installation. For now, I will assume I am doing something wrong with the JuliaPro configuration.

I installed JuliaPro 1.0.4 (latest version). I was able to install it with the default install path on a clean install of windows. Out of the box, it looks like parallel procs with packages do not work correctly. I am correcting the conclusion I drew earlier.

The following code works in the Julia console version (tried 1.0.4 and 1.1.1), but it is broken in JuliaPro (tried 1.0.3 and 1.0.4):

using Distributed, JuliaDB
@everywhere using JuliaDB

I think this is a bug with JuliaPro.

EDIT: Actually, after some re-installations, this problem went away. I may have installed JuliaPro and Julia console in a different order this time. Or I do have a memory of correcting the “PATH” environment variable, because I noticed that I missed the ending slash for julia bin directory.