Julia v1.7.3 has been released

Presumably Linux x86_64.

Follow this FAQ: How can I transfer the list of installed packages after updating my version of Julia?

That only applies when moving between minor versions of Julia. A patch release — like 1.7.2 to 1.7.3 — does not require any action.


Is it best for M1 users to go with 1.8beta3, which is what I’ve been doing with no problems?


Hello, I want to ask why I can not use Juliaup to update Julia?
I am using the Linux mint system, Juliaup 1.6.1, and currently using Julia 1.7.2.
I check in Juliaup there is no 1.7.3.

I guess it is just lagging behind a bit, has been discussed before

1 Like

On Linux GitHub - johnnychen94/jill.py: A cross-platform installer for the Julia programming language works better…


Thank you!

Surprised to hear the instability of Julia on M1 chips.

I plan to buy a new Mac soon. All of them are using M1 chips, instead of Intel chips. Any advice?

It doesn’t seem very surprising to me. M1 (etc.) is a new platform, so it takes time for all sorts of software to fully support it. Other programming languages have or have had similar issues. It’s a temporary problem, and there’s Rosetta as a backup solution.

I don’t have direct experience, though, but I’m sure many others can share theirs.


1.8 beta 3 native M1 support has been very good in my experience (although I run most of my simulations on a x86 linux cluster)


Same here. I’m using it on my MacBook Pro M1 Pro daily with no issues. 1.8.0 Beta3 multithreaded simulations.

1 Like

Thanks for recommendation. I’m probably bad at advertising but one good part of jill.py is that you don’t need a new jill version to upgrade your Julia version.

A fun fact: every time Julia makes a new release, jill.py star counts grow a few… :laughing:


I was a bit confused that the versioninfo (and the REPL splash screen) give the release date as 2022-05-06, which was the date of the last commit. I was thinking that this version had been out for nearly a month and somehow I hadn’t noticed.

1 Like

Yep, juliaup is always a bit behind because additional steps need to happen, but it should have been out for a while now. At some point we’ll integrate it full automatic into the release process :slight_smile:


After upgrading from v1.7.2 to v1.7.3, one of my scripts produced an error:

ERROR: LoadError: InitError: Artifact “OpenBLAS32” was not installed correctly. Try using Pkg; Pkg.instantiate() to re-install all missing resources.

The problem was indeed gone after I ran Pkg.instantiate(). I was under the global environment, not any project-specific virtual environment. I don’t know if this was actually due to the version upgrade.

I am currently on 1.6.6 and I would like to install 1.7.3 on the same machine. What about the packages? Should I save the ones in .julia and reinstall for 1.7.3? Or do 1.6.6 and 1.7.3 can share the current packages stored in .julia?

They share the packages on the disk, though not the environment. But you can copy over that easily, take .julia/environments/v1.6 and copy the contents to .julia/environments/v1.7 to make sure your new default environment has the same packages added.

According to my limited understanding it works like this:

Different versions of julia share .julia/packages. If you now install 1.7.3 (and have 1.6.x but no other 1.7.x), then a new environment .julia/environments/v1.7 is created. Initially there are no packages in v.1.7, you need to add them (with ] add packxxx). If a package has a new version which works only in v1.7 and higher then this will automatically get updated (into .julia/packages) while still retaining also the version for v1.6.

By just copying the environment one misses these possible package updates, I believe, and I recommend to add in v1.7 manually whenever something is missing.

When you decide to move for good to v1.7, then you can delete .julia/environments/v1.6. Packages which are needed only for v1.6, but not higher, i.e. obsolete packages, will then still hang around a while but eventually get automatically deleted by the package garbage collector.

1 Like

Julia 1.7.3 is now also available via the unstable channels of the Nix package manager via julia_17-bin (julia_17-bin: 1.7.2 -> 1.7.3 by rikhuijzer · Pull Request #174708 · NixOS/nixpkgs · GitHub).