# Disk Quota exceeded by activating environment

**URL:** <https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201>\
**Category:** New to Julia\
**Tags:** question, environment\
**Created:** [June 22, 2022, 7:24pm UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201 "2022-06-22T19:24:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![knoppers96](https://avatars.discourse-cdn.com/v4/letter/k/3ab097/32.png) [@knoppers96](https://discourse.julialang.org/u/knoppers96)\
**Post date:** [June 22, 2022, 7:24pm UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201/1 "2022-06-22T19:24:53Z")

</div>

Hello everybody,

I worked now for 6 months with julia and everything was fine, but I receive now a error callstack that is not understandable to me.  
I work via ssh on a ubuntu server, and there I received the following error message if I want to activate an environment or run a script:

 ![Bildschirmfoto 2022-06-22 um 21.14.38](https://global.discourse-cdn.com/julialang/original/3X/b/2/b2b6082e939d80882de1a470e89ecb5b34da5506.jpeg)

The error message says that it would have exceeded the disk quota, but that’s not true , I have still enough space left on the drive, I was able to copy still 100gb of videos on it.  
The message appears independent of the environment or script I would like to run.  
Additionally the scripts and environment still run on the other server which has the same mirrored drive (but this one has less cores, so I would like to stay on the one where it doesn’t work 😉 ).  
And the same scripts and environment run already several times on this server.

The only thing I could find to the topic in the forum was this:

> [@Disk quota exceeded](https://discourse.julialang.org/t/disk-quota-exceeded/15039):
>
> Hello, I’m getting this error now in the REPL I have plenty of disk space in the current directory and the install directory. Where should I look to see where I am running out of disk space? \u250c Error: Error in the keymap \u2502 exception = \u2502 SystemError: flush: Disk quota exceeded \u2502 Stacktrace: \u2502 [1] #systemerror#39(::Nothing, ::Function, ::String, ::Bool) at ./error.jl:106 \u2502 [2] systemerror at ./error.jl:106 [inlined] \u2502 [3] flush(::IOStream) …

But this did not help in my case.  
Has anybody an idea, wehre this comes from?

Thanks in advance!  
Moritz

---

<div class="post-metadata">

**Author:** ![daniel](https://sea2.discourse-cdn.com/julialang/user_avatar/discourse.julialang.org/daniel/32/6480_2.png) [@daniel](https://discourse.julialang.org/u/daniel)\
**Post date:** [June 22, 2022, 10:37pm UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201/2 "2022-06-22T22:37:49Z")

</div>

Two ideas:

Did you make sure you were logged in with the same user when you copied the video files?

Check that this is not an inode related issue, you can use `df -i` for that.

---

<div class="post-metadata">

**Author:** ![knoppers96](https://avatars.discourse-cdn.com/v4/letter/k/3ab097/32.png) [@knoppers96](https://discourse.julialang.org/u/knoppers96)\
**Post date:** [June 24, 2022, 8:05am UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201/3 "2022-06-24T08:05:05Z")

</div>

Hey,

thank you for your answer.  
Unfortunately this did not solve my issue.  
But I deleted the logs folder in the /.julia folder, and this solved my problem.

---

<div class="post-metadata">

**Author:** ![fgerick](https://sea2.discourse-cdn.com/julialang/user_avatar/discourse.julialang.org/fgerick/32/13228_2.png) [@fgerick](https://discourse.julialang.org/u/fgerick)\
**Post date:** [June 24, 2022, 9:54am UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201/4 "2022-06-24T09:54:06Z")

</div>

It sounds like your quota is restricted by the number of files, not just usage quota - maybe something to keep in mind when you run into this again.

---

<div class="post-metadata">

**Author:** ![natema](https://avatars.discourse-cdn.com/v4/letter/n/ba9def/32.png) [@natema](https://discourse.julialang.org/u/natema)\
**Post date:** [April 23, 2023, 8:35pm UTC](https://discourse.julialang.org/t/disk-quota-exceeded-by-activating-environment/83201/5 "2023-04-23T20:35:12Z")

</div>

I was getting a similar error. My `.julia` folder was about 33GB. Deleting it solved the issue.
