# Cannot install RecursiveArrayTools (latest version)

**URL:** <https://discourse.julialang.org/t/cannot-install-recursivearraytools-latest-version/115860>\
**Category:** General Usage\
**Tags:** question\
**Created:** [June 19, 2024, 1:17pm UTC](https://discourse.julialang.org/t/cannot-install-recursivearraytools-latest-version/115860 "2024-06-19T13:17:16Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ufechner7](https://sea2.discourse-cdn.com/julialang/user_avatar/discourse.julialang.org/ufechner7/32/51363_2.png) [@ufechner7](https://discourse.julialang.org/u/ufechner7)\
**Post date:** [June 19, 2024, 1:17pm UTC](https://discourse.julialang.org/t/cannot-install-recursivearraytools-latest-version/115860/1 "2024-06-19T13:17:16Z")

</div>

Today I cannot install the latest version of RecursiveArrayTools any longer. Yesterday it worked:

```julia
(tmp) pkg> add RecursiveArrayTools#v3.24.0
   Resolving package versions...
ERROR: Unsatisfiable requirements detected for package SymbolicIndexingInterface [2efcf032]:
 SymbolicIndexingInterface [2efcf032] log:
 ├─possible versions are: 0.1.0-0.3.22 or uninstalled
 └─restricted to versions 0.3.23-0.3 by RecursiveArrayTools [731186ca] — no versions left
   └─RecursiveArrayTools [731186ca] log:
     ├─possible versions are: 3.24.0 or uninstalled
     └─RecursiveArrayTools [731186ca] is fixed to version 3.24.0

```

How can this happen? Yesterday it worked, today not any longer?

---

<div class="post-metadata">

**Author:** ![ufechner7](https://sea2.discourse-cdn.com/julialang/user_avatar/discourse.julialang.org/ufechner7/32/51363_2.png) [@ufechner7](https://discourse.julialang.org/u/ufechner7)\
**Post date:** [June 19, 2024, 1:24pm UTC](https://discourse.julialang.org/t/cannot-install-recursivearraytools-latest-version/115860/2 "2024-06-19T13:24:21Z")

</div>

Created a bug report:

> <https://github.com/SciML/RecursiveArrayTools.jl/issues/391>
>
> \*\*Describe the bug 🐞\*\*
> 
> Create empty project
> \`\`\`
> mkdir tmp
> cd tmp
> julia --…project="."
> \`\`\`
> Install latest version of this package:
> \`\`\`
> (tmp) pkg\> add RecursiveArrayTools#v3.24.0
> Resolving package versions...
> ERROR: Unsatisfiable requirements detected for package SymbolicIndexingInterface \[2efcf032\]:
> SymbolicIndexingInterface \[2efcf032\] log:
> ├─possible versions are: 0.1.0-0.3.22 or uninstalled
> └─restricted to versions 0.3.23-0.3 by RecursiveArrayTools \[731186ca\] — no versions left
> └─RecursiveArrayTools \[731186ca\] log:
> ├─possible versions are: 3.24.0 or uninstalled
> └─RecursiveArrayTools \[731186ca\] is fixed to version 3.24.0
> \`\`\` 
> 
> \*\*Expected behavior\*\*
> 
> Installing of \`RecursiveArrayTools#v3.24.0\` succeeds.
> 
> \*\*Environment (please complete the following information):\*\*
> 
> - Output of \`using Pkg; Pkg.status()\`
> 
> \`\`\`julia
> julia\> using Pkg; Pkg.status()
> Status \`~/repos/tmp/Project.toml\`
> ⌃ \[731186ca\] RecursiveArrayTools v3.23.1
> Info Packages marked with ⌃ have new versions available and may be upgradable.
> \`\`\`
> 
> - Output of \`using Pkg; Pkg.status(; mode = PKGMODE\_MANIFEST)\`
> 
> \`\`\`julia
> julia\> using Pkg; Pkg.status(; mode = PKGMODE\_MANIFEST)
> Status \`~/repos/tmp/Manifest.toml\`
> \[7d9f7c33\] Accessors v0.1.36
> \[79e6a3ab\] Adapt v4.0.4
> \[4fba245c\] ArrayInterface v7.11.0
> \[a33af91c\] CompositionsBase v0.1.2
> \[187b0558\] ConstructionBase v1.5.5
> \[9a962f9c\] DataAPI v1.16.0
> \[e2d170a0\] DataValueInterfaces v1.0.0
> \[ffbed154\] DocStringExtensions v0.9.3
> \[e2ba6199\] ExprTools v0.1.10
> \[46192b85\] GPUArraysCore v0.1.6
> \[3587e190\] InverseFunctions v0.1.14
> \[82899510\] IteratorInterfaceExtensions v1.0.0
> \[1914dd2f\] MacroTools v0.5.13
> \[bac558e1\] OrderedCollections v1.6.3
> \[aea7be01\] PrecompileTools v1.2.1
> \[21216c6a\] Preferences v1.4.3
> \[3cdcf5f2\] RecipesBase v1.3.4
> ⌃ \[731186ca\] RecursiveArrayTools v3.23.1
> \[ae029012\] Requires v1.3.0
> \[7e49a35a\] RuntimeGeneratedFunctions v0.5.13
> \[1e83bf80\] StaticArraysCore v1.4.3
> \[2efcf032\] SymbolicIndexingInterface v0.3.22
> \[3783bdb8\] TableTraits v1.0.1
> \[bd369af6\] Tables v1.11.1
> \[56f22d72\] Artifacts
> \[2a0f44e3\] Base64
> \[ade2ca70\] Dates
> \[b77e0a4c\] InteractiveUtils
> \[76f85450\] LibGit2
> \[8f399da3\] Libdl
> \[37e2e46d\] LinearAlgebra
> \[56ddb016\] Logging
> \[d6f4376e\] Markdown
> \[ca575930\] NetworkOptions v1.2.0
> \[de0858da\] Printf
> \[9a3f8284\] Random
> \[ea8e919c\] SHA v0.7.0
> \[9e88b42a\] Serialization
> \[2f01184e\] SparseArrays v1.10.0
> \[10745b16\] Statistics v1.10.0
> \[4607b0f0\] SuiteSparse
> \[fa267f1f\] TOML v1.0.3
> \[8dfed614\] Test
> \[cf7118a7\] UUIDs
> \[4ec0a83e\] Unicode
> \[e66e0078\] CompilerSupportLibraries\_jll v1.1.1+0
> \[e37daf67\] LibGit2\_jll v1.6.4+0
> \[29816b5a\] LibSSH2\_jll v1.11.0+1
> \[c8ffd9c3\] MbedTLS\_jll v2.28.2+1
> \[4536629a\] OpenBLAS\_jll v0.3.23+4
> \[bea87d4a\] SuiteSparse\_jll v7.2.1+1
> \[8e850b90\] libblastrampoline\_jll v5.8.0+1
> Info Packages marked with ⌃ have new versions available and may be upgradable.
> \`\`\`
> 
> - Output of \`versioninfo()\`
> 
> \`\`\`julia
> julia\> versioninfo()
> Julia Version 1.10.4
> Commit 48d4fd48430 (2024-06-04 10:41 UTC)
> Build Info:
> Official https://julialang.org/ release
> Platform Info:
> OS: Linux (x86\_64-linux-gnu)
> CPU: 16 × AMD Ryzen 7 7840U w/ Radeon 780M Graphics
> WORD\_SIZE: 64
> LIBM: libopenlibm
> LLVM: libLLVM-15.0.7 (ORCJIT, znver3)
> Threads: 1 default, 0 interactive, 1 GC (on 16 virtual cores)
> \`\`\`
> 
> \*\*Additional context\*\*
> 
> Worked fine yesterday.

The problem is, I cannot install any of my own packages any longer. And this seams to be an issue with the Registry, it is somehow broken.
